phpstudy所有软件,已经通过360安全检测认证,phpstudy linux web面板(docker),已发布安全检测与修复

Linux版本的,云服务器上,在控制台不能使用php命令

旅丶途

云服务上安装了Linux版本的面板,用shell登陆控制台时,怎么去使用php命令,想安装composer,我去找了php的目录文件,好像运行不了

  • phpsutdy-猪哥
  • phpsutdy-猪哥  已被采纳  2019-11-09 13:39:002楼

    已经增加了  环境 变量设置  面板 里直接能操作

    +添加回复

  • 回复

    猪哥,不行啊,设置之后,好像php运行有问题,直接在控制台运行 php -r 'echo 1;'都会报错,然后我进入phpstudy/soft/php/php-7.3.8..../bin下直接运行./php -r 'echo 1;'就行,这是咋回事?????

    旅丶途  作者 · 2019-11-11 14:40:36
    回复
  • phpsutdy-猪哥
  • phpsutdy-猪哥    2019-10-28 15:38:531楼

    linux版本所有软件运行在docker里,所以你无法直接 操作, 下个版本在面板里可以配置 PHP版本的系统变量

    +添加回复

  • 回复

    我在服务上强行把phpstudy下面的php-7.3.8的php加入了PATH,并配置了相应的lib变量,php在bash控制台能用了,这样对后续升级有没有什么影响呢??

    旅丶途  作者 · 2019-10-28 15:44:52
    回复
微信扫码登陆

打开 微信
扫一扫登录